请选择 进入手机版 | 继续访问电脑版

极数云舟官方论坛

 找回密码
 立即注册

扫一扫,访问极数云舟官方论坛

搜索
热搜: 活动 交友 discuz
查看: 485|回复: 0

Linux [kipmi0]进程CPU 100%高占用率解决办法

[复制链接]

46

主题

46

帖子

230

积分

中级会员

Rank: 3Rank: 3

积分
230
发表于 2018-10-21 21:57:35 | 显示全部楼层 |阅读模式
服务器top进程上进程看到kipmi0经常占用很高的CPU甚至是100%

看看专业的说法:
  1. kipmi is supposed to run with low priority. When you say it consumes 70-90% of the CPUs, is that constant (does it still consume the processor when they are other tasks in the process queue that should have a larger slice of the CPU time) or the 70%/90% comes when the machine is idle?
  2. A second issue to investigate is whether you have pending controller issues (alarms of varying nature that are not resolved) and/or older versions of controller firmware.
复制代码
查看服务chkconfig 发现只有近似 ipmievd  服务,估计就是这个,跟网上资料说的ipmi有出入!

Fix:不需要修复
  1. No fix required. You should ignore increased CPU utilization as it has no impact on actual system performance.
复制代码
虽然这是一个利用空余的CPU资源进行一些接口自动调节的任务,但看着占那么多的资源还是怕出意外。

找到:可以临时降低
  1. echo 100 > /sys/module/ipmi_si/parameters/kipmid_max_busy_us
复制代码
In our system,after set this parameter,the cpu of kipmi0 decreased to 15%.确实执行上面命令后,所占CPU单核资源从100%降低到10%

You can try this.永久性降低
  1. To make the changes persistent you can configure the options for the ipmi_si kernel module.
  2. Create a file in /etc/modprobe.d/, i.e./etc/modprobe.d/ipmi.conf, and add the following content:
  3. # Prevent kipmi0 from consuming 100% CPU
  4. <font color="#4169e1">echo “options ipmi_si kipmid_max_busy_us=100”>/etc/modprobe.d/ipmi.conf</font>
复制代码
系统下次重启会自动调整

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|极数云舟官方论坛

GMT+8, 2020-2-29 14:10 , Processed in 0.044946 second(s), 19 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表